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S&S ECM Overview 
The S&S ECM used in the FTR750, is an alpha – N (throttle position and engine speed) based engine 
control system.   

The primary map used to control fuel is displayed in units of injector pulse width (msec - milliseconds - 
the amount of time per engine cycle that the injector is open).  

Fuel compensation maps (i.e. Engine Temperature Fuel Compensation) are in units of %. They increase 
or decrease the fuel by a percentage of the base fuel amount.  For example, if the engine is running with 
2.00 msec of fuel when there is no Engine Temperature Fuel Compensation, it will run with 2.20 msec of 
fuel when the Engine Temperature Fuel Compensation is set to 10% (2.00 msec + 0.1*2.00 msec = 2.20 
msec). 

The maps used to control ignition timing are in units of crank degrees Before Top Dead Center (BTDC).  
Compensation tables are added to the base ignition timing tables.  For example, if the engine is running 
with ignition timing at 20 deg BTDC with no Engine Temperature Ignition Compensation, it will run at 15 
deg BTDC with -5 deg of Engine Temperature Ignition Compensation (20 deg BTDC + -5 deg = 15 deg 
BTDC. 

The wiring diagram in the appendix of this manual shows the inputs and outputs of the ECM. 

Note, the terms ECM (Engine Control Module) and ECU (Engine Control Unit) are used interchangeably in 
this manual and the calibration software. 

 
 
S&S ECM Calibration Software 
Easimap Initial Setup 
After installing Easimap, below are a few items to check to be sure that the software is configured 
properly.   

Note, after changes are made, you may need to close Easimap, then re-open it for them to take effect. 

Easimap Profile 
Be sure that the “Profile:” found in the lower right hand corner of the screen reads “S&S Generic 
(Unlocked)” as shown in Figure 1. Note, you may have to maximize the Easimap window to see this.   

 

Figure 1: S&S Generic Unlocked Profile 

If the Profile does not appear as shown in Figure 1, go to the Options menu -> Select User Profile… (See 
Figure 2). 
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Figure 2: Select User Profile in Easimap 

Then, select “S&S Generic (Unlocked) (Profile for accessing unlocked S&S ECUs) as shown in Figure 3.  
Despite what it says, the Master profile does not offer unrestricted access and will not work with the 
S&S ECM. 

 

Figure 3: Selecting S&S Generic (Unlocked) Profile 

Easimap Preferences Setup 
Go to the Options menu -> Preferences as shown in Figure 4. 

 

Figure 4: Preferences in Easimap Options Menu 

Then, select the Miscellaneous tab as shown in Figure 5. 
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Figure 5: Easimap Preferences Miscellaneous Tab 

It is recommended to use the settings shown above.  Doing so will have the following effects: 

- Clicking to add a check mark in the box next to “Initially hide data when showing logging 
graph…” helps with large log files that can take a long time to open on slow computers. 
 

- Selecting “Last used folder” for all the default folders makes it convenient for performing 
repetitive tasks such as looking through several log files for a test session or comparing 
calibrations you have stored in a certain location on your computer. 

Easimap Configuration File 
Be sure that you have the correct configuration file (*.ec2) loaded. These can be seen in the upper 
middle to left of the Easimap screen (see Figure 6). The first 7 characters of the configuration file should 
match the ECU software version as shown in Figure 6.    

Note, if you are not connected to an ECM and reviewing or making changes to calibration files, be sure 
you know what software version you are using with your calibration files so you can select the correct 
*.ec2 file. 

 

Figure 6: Configuration File and ECU Software Version (First 7 Characters of Each Should Match)  
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The software should automatically locate the correct configuration file when you connect to the ECU.  If 
it does not or you are not working with the ECU connected, double click on the configuration file box to 
load the correct configuration file. 

Note, by default, Easimap will search for the *.ec2 file in the folder for the ECU model you are using.  In 
reference to Easimap, the FTR750 uses model number 996.  So, as you receive updated *.ec2 files you 
should store them in the 996 folder as shown in Figure 7. 

 

Figure 7: 996 Folder for Storing Configuration (*.ec2) files and ECU Code (*.h86) files 

Loading a Calibration File and ECU Code with Easimap 
The controls for loading calibration data files (*.ecc files or “chip-file” in Easimap) and ECU 
software/code can be found in the File menu in Easimap as shown in Figure 8. Note, there are buttons 
just below the File menu that perform the same functions. 

 

Figure 8: Controls for Loading Calibration Data Files (*.ecc) and ECU Software files (*.h86) in Easimap 

Below is a brief description of the functions shown in Figure 8: 

Load All Data From ECU… - Saves the *.ecc calibration data file from the ECU to the PC. 

Send All Data To ECU… - Used to load an *.ecc calibration data file from the PC to the ECU. 

Update ECU Software… - Use to change the*.h86 ECU software/code version in the ECU. 
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It is recommended to first save a copy of the calibration file in the ECU in case you need to go back to it. 

Calibration Work Overview 
This manual briefly covers some of the aspects of Easimap that are necessary to understand when 
performing calibration work.  It also shows some features of these programs that make calibration work 
easier. 

Calibration Data Locations 
When modifying calibrations, it is important to understand where the calibration data you are changing 
is stored. 

There are two sources of calibration data where you can make changes: 

1) The calibration file stored in the ECM 
2) A calibration file (*.ecc file) stored on your PC (Personal Computer) 

Easimap has features to tell you the source of the calibration data you are viewing and/or changing. 

Figure 9 shows an ignition map in Easimap.  The text at the top of the screen indicates that the source of 
the map is the ECU.  

 

Figure 9: Ignition Map from ECM in Easimap 

 

When viewing a map from a calibration file stored on the PC in Easimap, the calibration’s name and file 
location is shown (see Figure 10). 
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Figure 10: Ignition Map from *.ecc File in Easimap 

In this case, the file is stored in a folder created within Easimap’s Projects > 996 folder called FTR 
Calibrations (see Figure 11). 

 

Figure 11: Easimap's Projects > 996 Folder 

Accessing Calibration Maps in Easimap 
In Easimap, the calibration maps and settings can be accessed by selecting “Maps and Settings…” from 
the System menu (see Figure 12). 

 

Figure 12: Maps and Settings... in Easimap 
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After selecting Maps and Settings… the screen shown in Figure 13 will appear.  Note that the settings are 
arranged by function (i.e. Ignition settings can be found in the Ignition folder) and if you click on any 
individual map or setting a description of it will appear in the lower right of the window. 

 

Figure 13: Easimap Maps and Settings Window 

Changing a Map and Saving the Change 
If you make a change to a map in Easimap, a small asterisk will appear following the map title (see Figure 
14). 

 

Figure 14: Map Change Indicator in Easimap 

To save your changes in Easimap, click on “Send” or “Send/Close” found on the upper left of the screen 
shown in Figure 14. A screen will appear giving you the option of saving the changed map to a 
connected ECU or a calibration file of your choice.   

If you choose “Send” it will send the map but leave a copy of it open. This may be beneficial if you plan 
to make several, incremental changes to a map and send them one at a time to see the effects on 
engine running.   
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“Send/Close” simply sends the map to the calibration file or ECU and closes it.  This is good to do if you 
are changing several different maps and don’t want to leave copies of them open after they have been 
changed. 

3-D Map Layout in Easimap 
In Easimap, closed throttle cells are at the top and wide open throttle cells are at the bottom. (Figure 35) 

 

Figure 15: Spreadsheet in Easimap 

Note also that for 3-D maps in Easimap the load or throttle position axis is only shown in throttle sites. A 
“site” is a reference for how far open the throttle is.  Low numbers represent closed throttle. Higher 
numbers represent an increasingly open throttle. 

When using throttle site for calibration work, it is important to be aware that the main/primary fuel map 
uses a 32 site reference (sites 0-31) for load/throttle opening and most other 3-D maps (i.e. ignition and 
front/rear cylinder fuel trims) use a 16 site reference (0-15).  Be sure you are referencing the correct 
variables when making changes. 

Using Math Functions on Spreadsheets 
Easimap allow you to use math functions to adjust calibrations.  For example, you would like to increase 
the fuel amount by 5% in the area around idle.  

To do so, first select the cells around the idle region. Then, enter *1.05 (see Figure 16, multiply the cells 
by 1.05) and hit the Enter Key.  This will increase the values in the selected cells by 5%. 

If you would like to change the overall map by 5%, you can select any cell, hit Ctrl+A (select all) then type 
*1.05 and hit enter. 

Alternatively, you can use the Page Up and Page Down Keys of your keyboard to increase or decrease 
the value of a variable.  Holding the Shift key while doing this will increase the step size and holding the 
Ctrl key will increase it further. 

 



FTR750 Electrical Manual   Draft - March 12, 2017 

10 
 

 

 

Figure 16: Increasing Fuel in Idle Region by 5% Fuel  

 

Compare Data Function  
Easimap has a useful function called “Compare Device Data…” (see Figure 17). 

 

Figure 17: Compare Device Data in Easimap 

With this function, you can compare calibration files on the computer or with the one on the ECU.  
Running the function shows the differences in the calibrations (see Figure 18). 
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Figure 18: Result of Compare Device Data Function 

In Figure 18, the top of the window shows the devices that are being compared (the attached ECU and 
the 20170311 FTR750 Baseline.ecc file. The pane on the left shows where the two are different.  If you 
click on any of the maps shown there, the pane on the right will go to that map and show the 
differences. 

This tool is very helpful for seeing the changes that were made in a set of calibrations as well as being 
sure you have the correct settings when updating calibrations. 

Note, certain parameters such as Battery Voltage Readings and Engine Histogram Data will appear 
different in calibration files that are otherwise the same.  This is normal and expected. 

Keyboard Shortcut Keys 
Easimap has “shortcut keys” for accessing certain functions.  It is recommended to learn a few of these 
to eliminate the time it takes to position the mouse cursor to perform these functions.   

Commonly used Shortcut Keys in Easimap: 

F8 – Blend (Interpolate) Selected Area. Note, Easimap does not have an Average Selected Area function. 

Ctrl+U – Accesses the “Maps and Settings” Window (Note when in the Maps and Settings window it is 
helpful to use the up, down, left, and right arrow keys to move through the folders and parameters. 

“Alt” then “S” – Sends/saves the current map or setting to the data source of your choice. Leaves the 
map or setting window open. 

“Alt” then “C” – Same as above, but closes the map afterwards. 

“Alt” then “X” – Closes the currently active map. 
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Shift + F2 – When viewing a 3-D graph, this allows you to cycle through views where you can see the 
currently active row, multiple rows, or the whole 3-D graph. 

Shift+F3 – When viewing a 3-D graph, this allows you to switch between a 2-D view of the graph and a 3-
D view. 

S&S ECM Datalogger 
Easimap can be used to load log files from the ECM and clear the logger data.  

Most FTR750 calibrations are set up to log slightly less than 1.5 hours of data. For this reason, it is 
recommended to load and clear data from the logger often to avoid overwriting and losing data from 
test and race sessions. Loading and clearing the data often will also make the process faster since there 
will be less data than if the logger memory were completely full. 

Note, if you receive any error messages during the log file load process, it is likely that the data will be 
corrupted.  It is recommended that you reload the data before clearing/erasing it in the ECM. 

Note, loading data from and clearing the logger can take several minutes. It is recommended to attach a 
battery charger/maintainer to the motorcycle’s battery during this process. 

Loading a Log File from the ECU with Easimap 
First, connect to the ECU with Easimap then go to the Logging menu -> ECU Logging Setup…  

The screen shown in Figure 19 will appear. 

 

Figure 19:  On Board Logger Control Screen 

If the logger is running when connected to this screen, click on the STOP button to allow the UPLOAD 
button to be active.   

Next, click on the UPLOAD button, and the screen in Figure 20 will appear: 
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Figure 20: ECU Logger Data Upload Screen 

Generally, the default options are fine, but pay attention to the folder name and file location shown in 
the “Output Folder” in the middle of the screen.  You may wish to click on the “Browse” button and 
create a folder with a name that has more relevance to the test you are running. 

Now, click on “OK” and wait for the data to upload. The screen shown in Figure 21 will now appear. 

Note, loading data from and clearing the logger can take several minutes. It is recommended to attach a 
battery charger/maintainer to the motorcycle’s battery during this process. 

 

Figure 21: Loading data from ECU logger 

Depending on the settings used on the ECU Logger Data Upload screen, this will be followed by another 
screen that says “Building Output Files…”.  Once complete, depending on the settings used, the set of 
files created will appear in an open file from windows explorer as well as a set of windows for the 
Easimap Logged Data graph.  Using the Graph function will be discussed later.   
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Note, the files are named with a number in chronological order.  So, a file ending with a “-2” happened 
before a file ending with a “-3” and so on.  The first file in this sequence has no digit. 

After the data is loaded from the ECU, it is recommended that you clear the data from the ECU.  This 
makes loading data faster if you are planning to run a series of short tests.  

Go back to the Logging menu -> ECU Logging Setup… and click on CLEAR to clear the data from the ECU.  
Note that you may have to hit the STOP button first to do this. 

Importing Data from a Previously Saved Data (*.raw) File 
If you have only the raw data file to work with you can create Easimap log files and Excel importable 
*.csv files by clicking on the “Import” button towards the bottom of the On-Board Logger Control 
screen.  The ECU Logger Data Upload screen will then appear and the process from there is the same as 
described above. 

Working with Easimap Graphs 
By default, when you follow one of the previously described processes for uploading or importing data, 
an Easimap Graph will appear automatically.  If you want to look at a different set of data, go to the 
Logging menu -> Graph Data… and select the file you wish to view. 

If you select to initially hide the data as recommended in the Easimap Preferences Setup section, the 
screen will appear empty.  Simply click just to the left of the channel names to turn them off.  Engine 
Speed, if available, is usually a good reference to start with. 

Figure 22 below shows some of the basic controls used on the Easimap Graph: 

 

Figure 22: Easimap Logged Data Graph 
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Note, when working with large graphs or on a slow computer, and you need to zoom in or pan to a 
different part of the graph, it is recommended to right click on one of the channels and select “solo”, 
move to the location you want to view, then turn the channels back on that you want to see. 

Optional AiM Solo DL 
The information presented here is only a brief overview of the AiM Solo DL data logger and display unit.  
For more information on this unit, please refer to information found on the AiM web-site: 

http://www.aim-sportline.com/eng/products-bike/solo/index.htm 

Note: When wired on the bike, the Solo unit should power up when turning on the ignition switch.  
When the ignition switch is turned off the Solo will remain on for about five minutes (running on its 
internal battery).  This is normal operation. 

Race Studio Software 
The Solo works in conjunction with AiM’s Race Studio software.  Note that at the time of this writing, the 
Solo will not work with Race Studio 3.  You must use Race Studio 2.  Note, however, that Race Studio 2 is 
installed during the installation of Race Studio 3.  So, you can install either version. 

The Race Studio software can be found in the following link: 

http://www.aim-sportline.com/eng/download/software.htm 

AiM Solo DL Initial Setup 
Brand new Solo DL units will require setup through the Start Wizard.  This only needs to be done once 
and settings can be changed at a later time. 

Note, for Race Mode and Track Type settings the following are recommended: 

Race Mode = Speed (for a normal race in a circuit) 

Track Type = Circuit 

Setting up a New Track with AIM Solo 
The following should be performed prior to testing.  Note that options exist for selecting a track and 
setting beacons ahead of time.  However, this method works reliably for setting up the GPS system in 
any location. 

First go to the start/finish line of the track and stand approximately in the center of the track. Then, 
power on AIM Solo unit. You should see one of the two the following screens: 
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Next, press the button below the MENU option.  You should see the following: 
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Press the button below DOWN until System Management is highlighted then press the button below OK. 

 

 

 

 

The following screen will now appear: 
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Press the button below DOWN until Track Manager is highlighted, press OK and the following screen will 
appear: 

 

Press the DOWN button until Create New Track is highlighted and press OK. 

 

 

 

You will receive the following message to create a new track (press OK): 
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This will be followed by the message below to set the Start/Finish line.  Again, this should be done near 
the center of the track at the desired start/finish line.  If so, press OK. 

 

 

 

You will receive the following confirmation that the Start/Finish beacon has been set. Press EXIT to 
return to the main screen. 
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Race Studio Analysis (RSA) 
You can start Race Studio Analysis (RSA) by clicking on the shortcut on your Desktop: 

 

Or, click on the “Analysis” button if you are already working in the Race Studio software: 

 

Once in RSA, click on the test(s) you want to view and select Open Test from the bottom of the Test 
database window or from the menu that appears when you right click on the test.   

As shown below, channels that are selected to the left appear in the test laps view at the bottom of the 
screen.  Note the check boxes indicate which lap(s) will be shown when looking at the Measures Graph. 
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The image below shows some often-used controls and information on the Measures Graph 

 

Changing Channel Scaling in Measures Graph 
If a channel needs to be re-scaled in the Measures Graph, with a test open, go to the Modify menu of 
RSA and select Test Channels.  The following dialog box will appear where you can select the desired 
channel and change the scale.  
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Changing Units of Measure 
To change the units of measure, open RSA and close all open tests by first going to the Test Database 
tab, select open test(s) and click on Close Test: 

 

Then, under the File menu of RSA, select Preferences and the following dialog box will appear: 
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Optional Closed Loop System 
If you intend to use the closed loop capabilities of the S&S VFI system you will need to purchase the S&S 
wide band oxygen sensor kit part number LFT-1117. 

 
 

 

 

 

 

Appendices 
Appendix A - S&S ECM File Types 
There are several different file types used by the S&S ECM as well as the Easimap software.  Below is a 
summary: 

*.ecc – Calibration data file used by the ECM.  Sometimes referred to as a “Tune-File”, “Chip-File”, or 
“Data-File”. This is the collection of maps and other calibration settings. 

*.h86 – ECM Code (operating software) 

*.ec2 – Easimap configuration file.  It is important when using Easimap that you use the configuration 
file for the version of ECM Code you are using.  Normally, the first 7 characters of the *.ec2 file match 
that of the *.h86 code (i.e. 996bb102.h86 -> 996bb10c.ec2).  The 8th character in an *.ec2 file is the 
revision level. 

*.pge – Easimap page file.  Collection of data panels or gauges used when viewing ECM operating data 
with Easimap. 

*.raw – ECM datalogger file (raw data). 

*.lsn – Easimap logged data file. For viewing logged data, this must be accompanied by an *.lsn.dat file. 

*.lsn.dat – Easimap logged data file. For viewing logged data, this must be accompanied by an *.lsn file. 
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Appendix B - Wiring Diagram 
The base wiring diagram is shown below.   
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Appendix C – Race and Practice Checklists 
Below are checklists of things to do with the AiM Solo DL and S&S ECM before and after race and 
practice sessions. 

Pre-Session Checklist: 

 Calibrate AiM Solo DL accelerometer (should only need to be done once for a given mounting 
position on bike) 

 WEGO free-air calibration (this is not necessary every time, but definitely when changing 
sensors) 

 Clear ECM Logger memory and AiM Solo memory (if this is done regularly post-session, you 
should not need to check it again) 

 Set GPS Beacon (AiM Solo DL) 
 Check ECM for DTCs/Faults 
 Verify charging system operation (note that charging system usually does not start working until 

about 3500 – 4000 RPM) 
 If racing, check to be sure that closed-loop fuel control is turned off 

Post-Session Checklist: 

 Download AiM Solo DL Data and erase dash memory (after verifying data integrity) 
 Download ECM Logger Data and erase ECM Logger memory (after verifying data integrity) 
 At a minimum, quickly review S&S ECM Logger data to ensure no DTCs/Faults are set and that 

the charging system is working 
 


